[sumo-user] Vehicles braking when driving through the intersection

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[sumo-user] Vehicles braking when driving through the intersection

Neha Arora

Hi there,


At one of the signaled intersections in our network, we are observing that vehicles were braking while driving through the intersection when the signal is green and keeping unusually larger distance between previous vehicles. This results in lower intersection throughput. When we selected foe vehicles, they were in the neighboring through lane. For example, in the screenshot below, foe vehicles highlighted for the blue vehicle in the upper through lane are the three blue vehicles in the lower through lane.



Another case is that we find vehicles can be blocked by the other one on the right turn, where the thru vehicle shall have priority. The example below shows that the vehicle in the middle of the intersection has a “foe vehicle” colored as blue, on the right-turn lane in the other direction.

How do we go about debugging these issues?







_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
Reply | Threaded
Open this post in threaded view
|

Re: [sumo-user] Vehicles braking when driving through the intersection

Jakob Erdmann
Which sumo version are you using?

Am Sa., 13. Feb. 2021 um 21:05 Uhr schrieb Neha Arora <[hidden email]>:

Hi there,


At one of the signaled intersections in our network, we are observing that vehicles were braking while driving through the intersection when the signal is green and keeping unusually larger distance between previous vehicles. This results in lower intersection throughput. When we selected foe vehicles, they were in the neighboring through lane. For example, in the screenshot below, foe vehicles highlighted for the blue vehicle in the upper through lane are the three blue vehicles in the lower through lane.



Another case is that we find vehicles can be blocked by the other one on the right turn, where the thru vehicle shall have priority. The example below shows that the vehicle in the middle of the intersection has a “foe vehicle” colored as blue, on the right-turn lane in the other direction.

How do we go about debugging these issues?






_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user

_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
Reply | Threaded
Open this post in threaded view
|

Re: [sumo-user] Vehicles braking when driving through the intersection

Neha Arora
We see this problem in both 1.6 and 1.8.

On Mon, Feb 15, 2021 at 12:07 AM Jakob Erdmann <[hidden email]> wrote:
Which sumo version are you using?

Am Sa., 13. Feb. 2021 um 21:05 Uhr schrieb Neha Arora <[hidden email]>:

Hi there,


At one of the signaled intersections in our network, we are observing that vehicles were braking while driving through the intersection when the signal is green and keeping unusually larger distance between previous vehicles. This results in lower intersection throughput. When we selected foe vehicles, they were in the neighboring through lane. For example, in the screenshot below, foe vehicles highlighted for the blue vehicle in the upper through lane are the three blue vehicles in the lower through lane.



Another case is that we find vehicles can be blocked by the other one on the right turn, where the thru vehicle shall have priority. The example below shows that the vehicle in the middle of the intersection has a “foe vehicle” colored as blue, on the right-turn lane in the other direction.

How do we go about debugging these issues?






_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user

_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
Reply | Threaded
Open this post in threaded view
|

Re: [sumo-user] Vehicles braking when driving through the intersection

Jakob Erdmann
Regarding 1) what you are seeing is the effect of the zipper merge. In the current implementation, vehicles adapt their speed to fit into the zipper merge queue when within 100m or 10s of the merge point. It would probably be helpful to make this configurable for tuning the best compromise between space use and smoothness of flow. https://github.com/eclipse/sumo/issues/8240
Note, that all vehicles which approach a foe zipper link are marked as foes even though some of them are determined to pass after the ego vehicle.
If you wish to confirm this yourself, modify the edge length between the traffic light junction and the zipper junction.

Regarding 2) I would guess that this is an issue with the network file. Try rebuilding the network with netconvert 1.8 (netconvert -s old.net.xml -o new.net.xml) and check whether the network is different / the problem disappears. If not, send me the scenario for investigation.

regards,
Jakob

Am Di., 16. Feb. 2021 um 23:53 Uhr schrieb Neha Arora <[hidden email]>:
We see this problem in both 1.6 and 1.8.

On Mon, Feb 15, 2021 at 12:07 AM Jakob Erdmann <[hidden email]> wrote:
Which sumo version are you using?

Am Sa., 13. Feb. 2021 um 21:05 Uhr schrieb Neha Arora <[hidden email]>:

Hi there,


At one of the signaled intersections in our network, we are observing that vehicles were braking while driving through the intersection when the signal is green and keeping unusually larger distance between previous vehicles. This results in lower intersection throughput. When we selected foe vehicles, they were in the neighboring through lane. For example, in the screenshot below, foe vehicles highlighted for the blue vehicle in the upper through lane are the three blue vehicles in the lower through lane.



Another case is that we find vehicles can be blocked by the other one on the right turn, where the thru vehicle shall have priority. The example below shows that the vehicle in the middle of the intersection has a “foe vehicle” colored as blue, on the right-turn lane in the other direction.

How do we go about debugging these issues?






_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user

_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
Reply | Threaded
Open this post in threaded view
|

Re: [sumo-user] Vehicles braking when driving through the intersection

Neha Arora
Thanks Jakob! We changed the ZIPPER_ADAPT_TIME to 3s and ZIPPER_ADAPT_DIST to 10m and find that this set of parameters is more realistic in our current scenario. The problem is resolved now, thanks very much for the pointer and look forward to seeing this feature in the next version.

On Wed, Feb 17, 2021 at 12:22 AM Jakob Erdmann <[hidden email]> wrote:
Regarding 1) what you are seeing is the effect of the zipper merge. In the current implementation, vehicles adapt their speed to fit into the zipper merge queue when within 100m or 10s of the merge point. It would probably be helpful to make this configurable for tuning the best compromise between space use and smoothness of flow. https://github.com/eclipse/sumo/issues/8240
Note, that all vehicles which approach a foe zipper link are marked as foes even though some of them are determined to pass after the ego vehicle.
If you wish to confirm this yourself, modify the edge length between the traffic light junction and the zipper junction.

Regarding 2) I would guess that this is an issue with the network file. Try rebuilding the network with netconvert 1.8 (netconvert -s old.net.xml -o new.net.xml) and check whether the network is different / the problem disappears. If not, send me the scenario for investigation.

regards,
Jakob

Am Di., 16. Feb. 2021 um 23:53 Uhr schrieb Neha Arora <[hidden email]>:
We see this problem in both 1.6 and 1.8.

On Mon, Feb 15, 2021 at 12:07 AM Jakob Erdmann <[hidden email]> wrote:
Which sumo version are you using?

Am Sa., 13. Feb. 2021 um 21:05 Uhr schrieb Neha Arora <[hidden email]>:

Hi there,


At one of the signaled intersections in our network, we are observing that vehicles were braking while driving through the intersection when the signal is green and keeping unusually larger distance between previous vehicles. This results in lower intersection throughput. When we selected foe vehicles, they were in the neighboring through lane. For example, in the screenshot below, foe vehicles highlighted for the blue vehicle in the upper through lane are the three blue vehicles in the lower through lane.



Another case is that we find vehicles can be blocked by the other one on the right turn, where the thru vehicle shall have priority. The example below shows that the vehicle in the middle of the intersection has a “foe vehicle” colored as blue, on the right-turn lane in the other direction.

How do we go about debugging these issues?






_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user

_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user