[sumo-user] Loading simulation state fails after collision (stop on lane is not downstream)

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

[sumo-user] Loading simulation state fails after collision (stop on lane is not downstream)

Marcelo Andrade Rodrigues D Almeida
Hi everyone

I was running my application and found this error (Sumo version 1.8.0):

"Error: stop for vehicle '-gneE0__gneE3__light.42' on lane ':gneJ0_2_0' is not downstream the current route.
Quitting (on error).
'Connection' object has no attribute '_socket'"


This error occured after loading a state, saved after the following collision:

Step #1830.00
Warning: Vehicle '-gneE0__gneE3__light.42'; collision with vehicle '-gneE2__gneE0__light.46', lane=':gneJ0_2_0', gap=-1.00, time=1830.00 stage=move.




To reproduce the error locally, I loaded the state manually in my machine

Loading through python, I receive pretty much the same error, but for car 46 instead.

Screenshot from 2020-12-18 14-41-30.png

Alternatively, if I try to load it through the sumocfg and sumo-gui, I receive this error:

Screenshot from 2020-12-18 14-41-44.png


sumo files + script attached


Thank you in advance


Sincerely,

Marcelo d'Almeida

_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user

example.py (2K) Download Attachment
temp.zip (1008K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [sumo-user] Loading simulation state fails after collision (stop on lane is not downstream)

Jakob Erdmann
Thank you for reporting. This is now fixed (https://github.com/eclipse/sumo/issues/8030).

regards,
Jakob

Am Fr., 18. Dez. 2020 um 19:31 Uhr schrieb Marcelo Andrade Rodrigues D Almeida <[hidden email]>:
Hi everyone

I was running my application and found this error (Sumo version 1.8.0):

"Error: stop for vehicle '-gneE0__gneE3__light.42' on lane ':gneJ0_2_0' is not downstream the current route.
Quitting (on error).
'Connection' object has no attribute '_socket'"


This error occured after loading a state, saved after the following collision:

Step #1830.00
Warning: Vehicle '-gneE0__gneE3__light.42'; collision with vehicle '-gneE2__gneE0__light.46', lane=':gneJ0_2_0', gap=-1.00, time=1830.00 stage=move.




To reproduce the error locally, I loaded the state manually in my machine

Loading through python, I receive pretty much the same error, but for car 46 instead.

Screenshot from 2020-12-18 14-41-30.png

Alternatively, if I try to load it through the sumocfg and sumo-gui, I receive this error:

Screenshot from 2020-12-18 14-41-44.png


sumo files + script attached


Thank you in advance


Sincerely,

Marcelo d'Almeida
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user

_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
Reply | Threaded
Open this post in threaded view
|

Re: [sumo-user] Loading simulation state fails after collision (stop on lane is not downstream)

Marcelo Andrade Rodrigues D Almeida
Thank you


I just tested with the latest development version

| tar -xz
ENV SUMO_HOME=sumo-git
RUN mkdir sumo-git/build/cmake-build && cd sumo-git/build/cmake-build \
&& cmake ../.. && make -j$(nproc)


I'm still finding the same error (I don't know if it is the same cause, though)

See attached save states

Error:
Warning: Vehicle '-gneE3__gneE1__light.50'; collision with vehicle '-gneE1__gneE2__light.38', lane=':gneJ0_15_0', gap=-1.00, time=1482.00 stage=move.
Error: stop for vehicle '-gneE1__gneE2__light.38' on lane ':gneJ0_8_0' is not downstream the current route.
Quitting (on error).
'Connection' object has no attribute '_socket'



On Mon, Dec 21, 2020 at 7:47 AM Jakob Erdmann <[hidden email]> wrote:
Thank you for reporting. This is now fixed (https://github.com/eclipse/sumo/issues/8030).

regards,
Jakob

Am Fr., 18. Dez. 2020 um 19:31 Uhr schrieb Marcelo Andrade Rodrigues D Almeida <[hidden email]>:
Hi everyone

I was running my application and found this error (Sumo version 1.8.0):

"Error: stop for vehicle '-gneE0__gneE3__light.42' on lane ':gneJ0_2_0' is not downstream the current route.
Quitting (on error).
'Connection' object has no attribute '_socket'"


This error occured after loading a state, saved after the following collision:

Step #1830.00
Warning: Vehicle '-gneE0__gneE3__light.42'; collision with vehicle '-gneE2__gneE0__light.46', lane=':gneJ0_2_0', gap=-1.00, time=1830.00 stage=move.




To reproduce the error locally, I loaded the state manually in my machine

Loading through python, I receive pretty much the same error, but for car 46 instead.

Screenshot from 2020-12-18 14-41-30.png

Alternatively, if I try to load it through the sumocfg and sumo-gui, I receive this error:

Screenshot from 2020-12-18 14-41-44.png


sumo files + script attached


Thank you in advance


Sincerely,

Marcelo d'Almeida
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user

_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user

planning_for_step_1480__previous_phases_None__initial_step_1480__phase_6__68797eba-0c82-4f84-b79b-48937d0a730a_save_state_1490.0.sbx (975K) Download Attachment
planning_for_step_1480__previous_phases_None__initial_step_1480__phase_11__e343e6ea-1d81-4ac8-9df2-c28b788c73e7_save_state_1490.0.sbx (975K) Download Attachment
planning_for_step_1480__previous_phases_None__initial_step_1480__phase_10__73394e16-f653-4fc6-87ec-749ef5d7c2b9_save_state_1490.0.sbx (975K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [sumo-user] Loading simulation state fails after collision (stop on lane is not downstream)

Jakob Erdmann
All the attached states were written by version 1.8.0 but they need to be written by the latest development version (check the first comment line in the file).

Am Di., 22. Dez. 2020 um 16:56 Uhr schrieb Marcelo Andrade Rodrigues D Almeida <[hidden email]>:
Thank you


I just tested with the latest development version

| tar -xz
ENV SUMO_HOME=sumo-git
RUN mkdir sumo-git/build/cmake-build && cd sumo-git/build/cmake-build \
&& cmake ../.. && make -j$(nproc)


I'm still finding the same error (I don't know if it is the same cause, though)

See attached save states

Error:
Warning: Vehicle '-gneE3__gneE1__light.50'; collision with vehicle '-gneE1__gneE2__light.38', lane=':gneJ0_15_0', gap=-1.00, time=1482.00 stage=move.
Error: stop for vehicle '-gneE1__gneE2__light.38' on lane ':gneJ0_8_0' is not downstream the current route.
Quitting (on error).
'Connection' object has no attribute '_socket'



On Mon, Dec 21, 2020 at 7:47 AM Jakob Erdmann <[hidden email]> wrote:
Thank you for reporting. This is now fixed (https://github.com/eclipse/sumo/issues/8030).

regards,
Jakob

Am Fr., 18. Dez. 2020 um 19:31 Uhr schrieb Marcelo Andrade Rodrigues D Almeida <[hidden email]>:
Hi everyone

I was running my application and found this error (Sumo version 1.8.0):

"Error: stop for vehicle '-gneE0__gneE3__light.42' on lane ':gneJ0_2_0' is not downstream the current route.
Quitting (on error).
'Connection' object has no attribute '_socket'"


This error occured after loading a state, saved after the following collision:

Step #1830.00
Warning: Vehicle '-gneE0__gneE3__light.42'; collision with vehicle '-gneE2__gneE0__light.46', lane=':gneJ0_2_0', gap=-1.00, time=1830.00 stage=move.




To reproduce the error locally, I loaded the state manually in my machine

Loading through python, I receive pretty much the same error, but for car 46 instead.

Screenshot from 2020-12-18 14-41-30.png

Alternatively, if I try to load it through the sumocfg and sumo-gui, I receive this error:

Screenshot from 2020-12-18 14-41-44.png


sumo files + script attached


Thank you in advance


Sincerely,

Marcelo d'Almeida
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user

_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
Reply | Threaded
Open this post in threaded view
|

Re: [sumo-user] Loading simulation state fails after collision (stop on lane is not downstream)

Marcelo Andrade Rodrigues D Almeida

Yeah, I see!

I don't know what happened last time, but I invalidated the docker build cache one more time and the source from yesterday presented no problem (SUMO v1_8_0+0390-debec094ac)

Thank you



Sincerely,

Marcelo d'Almeida

On Wed, Dec 23, 2020 at 3:52 PM Jakob Erdmann <[hidden email]> wrote:
All the attached states were written by version 1.8.0 but they need to be written by the latest development version (check the first comment line in the file).

Am Di., 22. Dez. 2020 um 16:56 Uhr schrieb Marcelo Andrade Rodrigues D Almeida <[hidden email]>:
Thank you


I just tested with the latest development version

| tar -xz
ENV SUMO_HOME=sumo-git
RUN mkdir sumo-git/build/cmake-build && cd sumo-git/build/cmake-build \
&& cmake ../.. && make -j$(nproc)


I'm still finding the same error (I don't know if it is the same cause, though)

See attached save states

Error:
Warning: Vehicle '-gneE3__gneE1__light.50'; collision with vehicle '-gneE1__gneE2__light.38', lane=':gneJ0_15_0', gap=-1.00, time=1482.00 stage=move.
Error: stop for vehicle '-gneE1__gneE2__light.38' on lane ':gneJ0_8_0' is not downstream the current route.
Quitting (on error).
'Connection' object has no attribute '_socket'



On Mon, Dec 21, 2020 at 7:47 AM Jakob Erdmann <[hidden email]> wrote:
Thank you for reporting. This is now fixed (https://github.com/eclipse/sumo/issues/8030).

regards,
Jakob

Am Fr., 18. Dez. 2020 um 19:31 Uhr schrieb Marcelo Andrade Rodrigues D Almeida <[hidden email]>:
Hi everyone

I was running my application and found this error (Sumo version 1.8.0):

"Error: stop for vehicle '-gneE0__gneE3__light.42' on lane ':gneJ0_2_0' is not downstream the current route.
Quitting (on error).
'Connection' object has no attribute '_socket'"


This error occured after loading a state, saved after the following collision:

Step #1830.00
Warning: Vehicle '-gneE0__gneE3__light.42'; collision with vehicle '-gneE2__gneE0__light.46', lane=':gneJ0_2_0', gap=-1.00, time=1830.00 stage=move.




To reproduce the error locally, I loaded the state manually in my machine

Loading through python, I receive pretty much the same error, but for car 46 instead.

Screenshot from 2020-12-18 14-41-30.png

Alternatively, if I try to load it through the sumocfg and sumo-gui, I receive this error:

Screenshot from 2020-12-18 14-41-44.png


sumo files + script attached


Thank you in advance


Sincerely,

Marcelo d'Almeida
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user

_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
Reply | Threaded
Open this post in threaded view
|

Re: [sumo-user] Loading simulation state fails after collision (stop on lane is not downstream)

Marcelo Andrade Rodrigues D Almeida
Unfortunately, I encounted the error again.

Python console:
"Warning: State was written with sumo version 1.8.0 (present: v1_8_0+0346-debec094ac)!
Error: stop for vehicle '-gneE2__gneE0__light.46' on lane ':gneJ0_19_0' is not downstream the current route.
Quitting (on error)."

Despite the above warning about version mismatch, the file states it was generated with version v1_8_0+0346-debec094ac


Sincerely,

Marcelo d'Almeida

On Sat, Dec 26, 2020 at 1:43 PM Marcelo Andrade Rodrigues D Almeida <[hidden email]> wrote:

Yeah, I see!

I don't know what happened last time, but I invalidated the docker build cache one more time and the source from yesterday presented no problem (SUMO v1_8_0+0390-debec094ac)

Thank you



Sincerely,

Marcelo d'Almeida

On Wed, Dec 23, 2020 at 3:52 PM Jakob Erdmann <[hidden email]> wrote:
All the attached states were written by version 1.8.0 but they need to be written by the latest development version (check the first comment line in the file).

Am Di., 22. Dez. 2020 um 16:56 Uhr schrieb Marcelo Andrade Rodrigues D Almeida <[hidden email]>:
Thank you


I just tested with the latest development version

| tar -xz
ENV SUMO_HOME=sumo-git
RUN mkdir sumo-git/build/cmake-build && cd sumo-git/build/cmake-build \
&& cmake ../.. && make -j$(nproc)


I'm still finding the same error (I don't know if it is the same cause, though)

See attached save states

Error:
Warning: Vehicle '-gneE3__gneE1__light.50'; collision with vehicle '-gneE1__gneE2__light.38', lane=':gneJ0_15_0', gap=-1.00, time=1482.00 stage=move.
Error: stop for vehicle '-gneE1__gneE2__light.38' on lane ':gneJ0_8_0' is not downstream the current route.
Quitting (on error).
'Connection' object has no attribute '_socket'



On Mon, Dec 21, 2020 at 7:47 AM Jakob Erdmann <[hidden email]> wrote:
Thank you for reporting. This is now fixed (https://github.com/eclipse/sumo/issues/8030).

regards,
Jakob

Am Fr., 18. Dez. 2020 um 19:31 Uhr schrieb Marcelo Andrade Rodrigues D Almeida <[hidden email]>:
Hi everyone

I was running my application and found this error (Sumo version 1.8.0):

"Error: stop for vehicle '-gneE0__gneE3__light.42' on lane ':gneJ0_2_0' is not downstream the current route.
Quitting (on error).
'Connection' object has no attribute '_socket'"


This error occured after loading a state, saved after the following collision:

Step #1830.00
Warning: Vehicle '-gneE0__gneE3__light.42'; collision with vehicle '-gneE2__gneE0__light.46', lane=':gneJ0_2_0', gap=-1.00, time=1830.00 stage=move.




To reproduce the error locally, I loaded the state manually in my machine

Loading through python, I receive pretty much the same error, but for car 46 instead.

Screenshot from 2020-12-18 14-41-30.png

Alternatively, if I try to load it through the sumocfg and sumo-gui, I receive this error:

Screenshot from 2020-12-18 14-41-44.png


sumo files + script attached


Thank you in advance


Sincerely,

Marcelo d'Almeida
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user

_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user

test_round_0__206d41b8-edb1-4989-bed0-a83eec8e9a6c_save_state_380.0.sbx (732K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [sumo-user] Loading simulation state fails after collision (stop on lane is not downstream)

Jakob Erdmann
The error message uses the version string directly from the file. I would bet that there is an older state file on your machine that is being read.

Am Sa., 26. Dez. 2020 um 19:28 Uhr schrieb Marcelo Andrade Rodrigues D Almeida <[hidden email]>:
Unfortunately, I encounted the error again.

Python console:
"Warning: State was written with sumo version 1.8.0 (present: v1_8_0+0346-debec094ac)!
Error: stop for vehicle '-gneE2__gneE0__light.46' on lane ':gneJ0_19_0' is not downstream the current route.
Quitting (on error)."

Despite the above warning about version mismatch, the file states it was generated with version v1_8_0+0346-debec094ac


Sincerely,

Marcelo d'Almeida

On Sat, Dec 26, 2020 at 1:43 PM Marcelo Andrade Rodrigues D Almeida <[hidden email]> wrote:

Yeah, I see!

I don't know what happened last time, but I invalidated the docker build cache one more time and the source from yesterday presented no problem (SUMO v1_8_0+0390-debec094ac)

Thank you



Sincerely,

Marcelo d'Almeida

On Wed, Dec 23, 2020 at 3:52 PM Jakob Erdmann <[hidden email]> wrote:
All the attached states were written by version 1.8.0 but they need to be written by the latest development version (check the first comment line in the file).

Am Di., 22. Dez. 2020 um 16:56 Uhr schrieb Marcelo Andrade Rodrigues D Almeida <[hidden email]>:
Thank you


I just tested with the latest development version

| tar -xz
ENV SUMO_HOME=sumo-git
RUN mkdir sumo-git/build/cmake-build && cd sumo-git/build/cmake-build \
&& cmake ../.. && make -j$(nproc)


I'm still finding the same error (I don't know if it is the same cause, though)

See attached save states

Error:
Warning: Vehicle '-gneE3__gneE1__light.50'; collision with vehicle '-gneE1__gneE2__light.38', lane=':gneJ0_15_0', gap=-1.00, time=1482.00 stage=move.
Error: stop for vehicle '-gneE1__gneE2__light.38' on lane ':gneJ0_8_0' is not downstream the current route.
Quitting (on error).
'Connection' object has no attribute '_socket'



On Mon, Dec 21, 2020 at 7:47 AM Jakob Erdmann <[hidden email]> wrote:
Thank you for reporting. This is now fixed (https://github.com/eclipse/sumo/issues/8030).

regards,
Jakob

Am Fr., 18. Dez. 2020 um 19:31 Uhr schrieb Marcelo Andrade Rodrigues D Almeida <[hidden email]>:
Hi everyone

I was running my application and found this error (Sumo version 1.8.0):

"Error: stop for vehicle '-gneE0__gneE3__light.42' on lane ':gneJ0_2_0' is not downstream the current route.
Quitting (on error).
'Connection' object has no attribute '_socket'"


This error occured after loading a state, saved after the following collision:

Step #1830.00
Warning: Vehicle '-gneE0__gneE3__light.42'; collision with vehicle '-gneE2__gneE0__light.46', lane=':gneJ0_2_0', gap=-1.00, time=1830.00 stage=move.




To reproduce the error locally, I loaded the state manually in my machine

Loading through python, I receive pretty much the same error, but for car 46 instead.

Screenshot from 2020-12-18 14-41-30.png

Alternatively, if I try to load it through the sumocfg and sumo-gui, I receive this error:

Screenshot from 2020-12-18 14-41-44.png


sumo files + script attached


Thank you in advance


Sincerely,

Marcelo d'Almeida
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user

_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
Reply | Threaded
Open this post in threaded view
|

Re: [sumo-user] Loading simulation state fails after collision (stop on lane is not downstream)

Marcelo Andrade Rodrigues D Almeida
Hi again

I cleaned all old state files as a precaution, and I still face the same problem.

See attached log and state files

Thank you in advance


Sincerely,

Marcelo d'Almeida


On Mon, Jan 4, 2021 at 6:20 AM Jakob Erdmann <[hidden email]> wrote:
The error message uses the version string directly from the file. I would bet that there is an older state file on your machine that is being read.

Am Sa., 26. Dez. 2020 um 19:28 Uhr schrieb Marcelo Andrade Rodrigues D Almeida <[hidden email]>:
Unfortunately, I encounted the error again.

Python console:
"Warning: State was written with sumo version 1.8.0 (present: v1_8_0+0346-debec094ac)!
Error: stop for vehicle '-gneE2__gneE0__light.46' on lane ':gneJ0_19_0' is not downstream the current route.
Quitting (on error)."

Despite the above warning about version mismatch, the file states it was generated with version v1_8_0+0346-debec094ac


Sincerely,

Marcelo d'Almeida

On Sat, Dec 26, 2020 at 1:43 PM Marcelo Andrade Rodrigues D Almeida <[hidden email]> wrote:

Yeah, I see!

I don't know what happened last time, but I invalidated the docker build cache one more time and the source from yesterday presented no problem (SUMO v1_8_0+0390-debec094ac)

Thank you



Sincerely,

Marcelo d'Almeida

On Wed, Dec 23, 2020 at 3:52 PM Jakob Erdmann <[hidden email]> wrote:
All the attached states were written by version 1.8.0 but they need to be written by the latest development version (check the first comment line in the file).

Am Di., 22. Dez. 2020 um 16:56 Uhr schrieb Marcelo Andrade Rodrigues D Almeida <[hidden email]>:
Thank you


I just tested with the latest development version

| tar -xz
ENV SUMO_HOME=sumo-git
RUN mkdir sumo-git/build/cmake-build && cd sumo-git/build/cmake-build \
&& cmake ../.. && make -j$(nproc)


I'm still finding the same error (I don't know if it is the same cause, though)

See attached save states

Error:
Warning: Vehicle '-gneE3__gneE1__light.50'; collision with vehicle '-gneE1__gneE2__light.38', lane=':gneJ0_15_0', gap=-1.00, time=1482.00 stage=move.
Error: stop for vehicle '-gneE1__gneE2__light.38' on lane ':gneJ0_8_0' is not downstream the current route.
Quitting (on error).
'Connection' object has no attribute '_socket'



On Mon, Dec 21, 2020 at 7:47 AM Jakob Erdmann <[hidden email]> wrote:
Thank you for reporting. This is now fixed (https://github.com/eclipse/sumo/issues/8030).

regards,
Jakob

Am Fr., 18. Dez. 2020 um 19:31 Uhr schrieb Marcelo Andrade Rodrigues D Almeida <[hidden email]>:
Hi everyone

I was running my application and found this error (Sumo version 1.8.0):

"Error: stop for vehicle '-gneE0__gneE3__light.42' on lane ':gneJ0_2_0' is not downstream the current route.
Quitting (on error).
'Connection' object has no attribute '_socket'"


This error occured after loading a state, saved after the following collision:

Step #1830.00
Warning: Vehicle '-gneE0__gneE3__light.42'; collision with vehicle '-gneE2__gneE0__light.46', lane=':gneJ0_2_0', gap=-1.00, time=1830.00 stage=move.




To reproduce the error locally, I loaded the state manually in my machine

Loading through python, I receive pretty much the same error, but for car 46 instead.

Screenshot from 2020-12-18 14-41-30.png

Alternatively, if I try to load it through the sumocfg and sumo-gui, I receive this error:

Screenshot from 2020-12-18 14-41-44.png


sumo files + script attached


Thank you in advance


Sincerely,

Marcelo d'Almeida
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user

_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user

planning_for_step_1640__previous_phases_0-1__initial_step_1650__phase_0__400d5666-2f3c-4a6e-9433-9d501e450bf0_save_state_1660.0.sbx (707K) Download Attachment
planning_for_step_1640__previous_phases_0-1__initial_step_1650__phase_1__8288a347-591c-47a8-9cf1-82bff9ce6aed_save_state_1660.0.sbx (707K) Download Attachment
f_kjlm6dld4 (8K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [sumo-user] Loading simulation state fails after collision (stop on lane is not downstream)

Jakob Erdmann
I can confirm that this is a distinct bug from the one that was fixed before.

Am Mi., 6. Jan. 2021 um 17:07 Uhr schrieb Marcelo Andrade Rodrigues D Almeida <[hidden email]>:
Hi again

I cleaned all old state files as a precaution, and I still face the same problem.

See attached log and state files

Thank you in advance


Sincerely,

Marcelo d'Almeida


On Mon, Jan 4, 2021 at 6:20 AM Jakob Erdmann <[hidden email]> wrote:
The error message uses the version string directly from the file. I would bet that there is an older state file on your machine that is being read.

Am Sa., 26. Dez. 2020 um 19:28 Uhr schrieb Marcelo Andrade Rodrigues D Almeida <[hidden email]>:
Unfortunately, I encounted the error again.

Python console:
"Warning: State was written with sumo version 1.8.0 (present: v1_8_0+0346-debec094ac)!
Error: stop for vehicle '-gneE2__gneE0__light.46' on lane ':gneJ0_19_0' is not downstream the current route.
Quitting (on error)."

Despite the above warning about version mismatch, the file states it was generated with version v1_8_0+0346-debec094ac


Sincerely,

Marcelo d'Almeida

On Sat, Dec 26, 2020 at 1:43 PM Marcelo Andrade Rodrigues D Almeida <[hidden email]> wrote:

Yeah, I see!

I don't know what happened last time, but I invalidated the docker build cache one more time and the source from yesterday presented no problem (SUMO v1_8_0+0390-debec094ac)

Thank you



Sincerely,

Marcelo d'Almeida

On Wed, Dec 23, 2020 at 3:52 PM Jakob Erdmann <[hidden email]> wrote:
All the attached states were written by version 1.8.0 but they need to be written by the latest development version (check the first comment line in the file).

Am Di., 22. Dez. 2020 um 16:56 Uhr schrieb Marcelo Andrade Rodrigues D Almeida <[hidden email]>:
Thank you


I just tested with the latest development version

| tar -xz
ENV SUMO_HOME=sumo-git
RUN mkdir sumo-git/build/cmake-build && cd sumo-git/build/cmake-build \
&& cmake ../.. && make -j$(nproc)


I'm still finding the same error (I don't know if it is the same cause, though)

See attached save states

Error:
Warning: Vehicle '-gneE3__gneE1__light.50'; collision with vehicle '-gneE1__gneE2__light.38', lane=':gneJ0_15_0', gap=-1.00, time=1482.00 stage=move.
Error: stop for vehicle '-gneE1__gneE2__light.38' on lane ':gneJ0_8_0' is not downstream the current route.
Quitting (on error).
'Connection' object has no attribute '_socket'



On Mon, Dec 21, 2020 at 7:47 AM Jakob Erdmann <[hidden email]> wrote:
Thank you for reporting. This is now fixed (https://github.com/eclipse/sumo/issues/8030).

regards,
Jakob

Am Fr., 18. Dez. 2020 um 19:31 Uhr schrieb Marcelo Andrade Rodrigues D Almeida <[hidden email]>:
Hi everyone

I was running my application and found this error (Sumo version 1.8.0):

"Error: stop for vehicle '-gneE0__gneE3__light.42' on lane ':gneJ0_2_0' is not downstream the current route.
Quitting (on error).
'Connection' object has no attribute '_socket'"


This error occured after loading a state, saved after the following collision:

Step #1830.00
Warning: Vehicle '-gneE0__gneE3__light.42'; collision with vehicle '-gneE2__gneE0__light.46', lane=':gneJ0_2_0', gap=-1.00, time=1830.00 stage=move.




To reproduce the error locally, I loaded the state manually in my machine

Loading through python, I receive pretty much the same error, but for car 46 instead.

Screenshot from 2020-12-18 14-41-30.png

Alternatively, if I try to load it through the sumocfg and sumo-gui, I receive this error:

Screenshot from 2020-12-18 14-41-44.png


sumo files + script attached


Thank you in advance


Sincerely,

Marcelo d'Almeida
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user
_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user

_______________________________________________
sumo-user mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user